blob: 66bf1eaa48fd7826a547b9ed1542ef76266c706f [file] [log] [blame]
Samuel Shuertf1d6e992023-11-24 17:28:33 -05001{ pkgs, config, inputs, ... }: {
2 programs.zsh.enable = true;
3 users.users.coded.shell = pkgs.zsh;
4
Samuel Shuert80c2dd42023-12-01 22:03:34 -05005 environment.systemPackages = with pkgs; [
6 bmon
7 wget
Samuel Shuertf6c41b52023-12-02 13:21:47 -05008 ripgrep
Samuel Shuert80c2dd42023-12-01 22:03:34 -05009 ];
10
Samuel Shuertf1d6e992023-11-24 17:28:33 -050011 home-manager.users.coded.programs = {
12 # ZSH
13 zsh = {
14 enable = true;
15 enableAutosuggestions = true;
16 enableCompletion = true;
17 autocd = true;
18 defaultKeymap = "emacs";
19
20 shellAliases = {
21 rebuild = "sudo nixos-rebuild switch --flake /home/coded/nixConfig/";
22 "gr!" = "git review";
23 clr = "clear";
24 pnpx = "pnpm dlx";
Samuel Shuert80c2dd42023-12-01 22:03:34 -050025 print3d = "sudo /run/current-system/sw/bin/pronsole.py";
26 nh = "wget -O ~/Documents/hashCheck $1 | nix hash file ~/Documents/hashCheck";
Samuel Shuertf6c41b52023-12-02 13:21:47 -050027 edit = "nvim";
28 neovim = "nvim";
29 v = "nvim";
Samuel Shuertf1d6e992023-11-24 17:28:33 -050030 };
31
32 dirHashes = { code = "$HOME/Documents/programming"; };
33
34 history = { extended = true; };
35 historySubstringSearch.enable = true;
36
37 oh-my-zsh = {
38 enable = true;
39 plugins = [ "git" ];
40 };
41 };
Samuel Shuert80c2dd42023-12-01 22:03:34 -050042
Samuel Shuertf1d6e992023-11-24 17:28:33 -050043 # Starship
44 starship = {
45 enable = true;
46 settings = { format = "$all"; };
47 };
48
49 # Alacritty
50 alacritty = {
51 enable = true;
52 settings = {
53 window.dimensions = {
54 lines = 40;
55 columns = 150;
56 };
57 import = [
58 "${inputs.alacritty-themes}/themes/Catppuccin-Mocha.yml"
59 ];
60 };
61 };
62
Samuel Shuertf1d6e992023-11-24 17:28:33 -050063 # Nix-index
64 nix-index.enable = true;
65
66 # thefuck
67 thefuck = {
68 enable = true;
69 enableInstantMode = true;
70 };
71 };
72
73 environment.pathsToLink =
74 [ "/share/zsh" ]; # needed for completing system packages
75}