blob: ccf714ab9015393382268d14df37d6ef3c23dc16 [file] [log] [blame]
Skyler Grey1e2187f2023-03-03 22:45:10 +00001{
2 description = "A flake to deploy and configure Clicks' NixOS server";
3
Skyler Grey07584fb2023-05-01 21:37:13 +00004 inputs.nixpkgs.url = "github:nixos/nixpkgs/nixos-22.11";
Skyler Greya7fbaee2023-05-12 00:29:20 +00005 inputs.nixpkgs-unstable.url = "github:nixos/nixpkgs/nixpkgs-unstable";
Skyler Grey061574c2023-05-01 21:39:24 +00006 inputs.flake-utils.url = "github:numtide/flake-utils";
Skyler Grey1e2187f2023-03-03 22:45:10 +00007 inputs.deploy-rs.url = "github:serokell/deploy-rs";
Skyler Grey07584fb2023-05-01 21:37:13 +00008 inputs.home-manager.url = "github:nix-community/home-manager/release-22.11";
Skyler Greya7fbaee2023-05-12 00:29:20 +00009 inputs.sops-nix.url = "github:Mic92/sops-nix";
Skyler Greya78aa672023-05-20 13:48:18 +020010 inputs.scalpel.url = "github:polygon/scalpel";
Skyler Grey1e2187f2023-03-03 22:45:10 +000011
Skyler Greyfed0bb12023-05-01 21:42:03 +000012 inputs.home-manager.inputs.nixpkgs.follows = "nixpkgs";
13 inputs.home-manager.inputs.utils.follows = "deploy-rs/utils";
14
Skyler Greya7fbaee2023-05-12 00:29:20 +000015 inputs.sops-nix.inputs.nixpkgs.follows = "nixpkgs";
16
Skyler Greya78aa672023-05-20 13:48:18 +020017 inputs.scalpel.inputs.nixpkgs.follows = "nixpkgs";
18 inputs.scalpel.inputs.sops-nix.follows = "sops-nix";
19
20 outputs = { self, nixpkgs, deploy-rs, home-manager, sops-nix, scalpel, nixpkgs-unstable, ... }@inputs:
Skyler Grey07584fb2023-05-01 21:37:13 +000021 let
22 system = "x86_64-linux";
23 pkgs = import nixpkgs {
24 inherit system;
25 config.allowUnfree = true;
26 };
Skyler Greya7fbaee2023-05-12 00:29:20 +000027 pkgs-unstable = import nixpkgs-unstable {
28 inherit system;
29 config.allowUnfree = true;
30 };
Skyler Grey07584fb2023-05-01 21:37:13 +000031 in
Skyler Greyb3516c22023-05-24 19:17:11 +020032 rec {
Skyler Grey07584fb2023-05-01 21:37:13 +000033 nixosConfigurations.clicks =
Skyler Greya78aa672023-05-20 13:48:18 +020034 let
35 base = nixpkgs.lib.nixosSystem {
36 inherit system pkgs;
37 modules = [
38 ./default/configuration.nix
39 ./default/hardware-configuration.nix
40 ./modules/caddy.nix
41 ./modules/clamav.nix
42 ./modules/code-server.nix
43 ./modules/dmarc.nix
44 ./modules/dnsmasq.nix
45 ./modules/doas.nix
46 ./modules/docker.nix
47 ./modules/ecryptfs.nix
48 ./modules/fail2ban.nix
49 ./modules/fuck.nix
50 ./modules/git.nix
51 ./modules/grafana.nix
52 ./modules/home-manager-users.nix
53 ./modules/kitty.nix
Skyler Grey480fd8b2023-05-24 19:11:16 +020054 ./modules/loginctl-linger.nix
Skyler Greya78aa672023-05-20 13:48:18 +020055 ./modules/matrix.nix
56 ./modules/mongodb.nix
57 ./modules/node.nix
58 ./modules/postgres.nix
59 ./modules/samba.nix
60 ./modules/scalpel.nix
Skyler Grey5b2c0382023-05-29 11:09:05 +020061 ./modules/static-ip.nix
Skyler Greya78aa672023-05-20 13:48:18 +020062 ./modules/tesseract.nix
63 sops-nix.nixosModules.sops
64 {
65 users.mutableUsers = false;
66 _module.args = { inherit pkgs-unstable; };
67 }
68 ];
69 specialArgs = { base = null; };
70 };
71 in
72 base.extendModules {
Skyler Grey07584fb2023-05-01 21:37:13 +000073 modules = [
Skyler Greya78aa672023-05-20 13:48:18 +020074 scalpel.nixosModules.scalpel
Skyler Grey07584fb2023-05-01 21:37:13 +000075 ];
Skyler Greya78aa672023-05-20 13:48:18 +020076 specialArgs = { inherit base; };
Skyler Grey4f3e6062023-03-04 01:29:29 +000077 };
Skyler Grey07584fb2023-05-01 21:37:13 +000078
Skyler Greyb3516c22023-05-24 19:17:11 +020079 nixosConfigurations.clicks-without-mongodb =
80 nixosConfigurations.clicks.extendModules {
81 modules = [
82 { services.mongodb.enable = nixpkgs.lib.mkForce false; }
83 ];
84 };
85
Skyler Grey07584fb2023-05-01 21:37:13 +000086 deploy.nodes.clicks = {
87 sudo = "doas -u";
88 profiles = {
89 system = {
90 remoteBuild = true;
91 user = "root";
92 path = deploy-rs.lib.x86_64-linux.activate.nixos
93 self.nixosConfigurations.clicks;
94 };
95 } // (
96 let
97 mkServiceConfig = service: {
98 remoteBuild = true;
99 user = service;
100
101 profilePath = "/nix/var/nix/profiles/per-user/${service}/home-manager";
102 path =
103 deploy-rs.lib.x86_64-linux.activate.home-manager (home-manager.lib.homeManagerConfiguration
104 {
105 inherit pkgs;
106 modules = [
107 {
108 home.homeDirectory = "/services/${service}";
109 home.username = service;
110 home.stateVersion = "22.11";
111 programs.home-manager.enable = true;
112 }
113 "${./services}/${service}"
114 ];
115 });
116 };
117 in
118 nixpkgs.lib.pipe ./services [
119 builtins.readDir
120 (nixpkgs.lib.filterAttrs (_name: value: value == "directory"))
121 builtins.attrNames
122 (map (name: {
123 inherit name; value = mkServiceConfig name;
124 }))
125 builtins.listToAttrs
126 ]
Skyler Grey5b2c0382023-05-29 11:09:05 +0200127 ) // (
128 let
129 mkBlankConfig = username:
130 {
131 remoteBuild = true;
132 user = username;
133
134 profilePath = "/nix/var/nix/profiles/per-user/${username}/home-manager";
135 path =
136 deploy-rs.lib.x86_64-linux.activate.home-manager (home-manager.lib.homeManagerConfiguration
137 {
138 inherit pkgs;
139 modules = [
140 {
141 home.username = username;
142 home.stateVersion = "22.11";
143 programs.home-manager.enable = true;
144 }
145 "${./homes}/${username}"
146 ];
147 });
148 };
149 in
150 nixpkgs.lib.pipe ./homes [
151 builtins.readDir
152 (nixpkgs.lib.filterAttrs (_name: value: value == "directory"))
153 builtins.attrNames
154 (map (name: {
155 inherit name; value = mkBlankConfig name;
156 }))
157 builtins.listToAttrs
158 ]
Skyler Grey07584fb2023-05-01 21:37:13 +0000159 );
160 hostname = "clicks";
161 profilesOrder = [ "system" ];
Skyler Grey1e2187f2023-03-03 22:45:10 +0000162 };
Skyler Grey1e2187f2023-03-03 22:45:10 +0000163
Skyler Grey07584fb2023-05-01 21:37:13 +0000164 formatter.x86_64-linux = nixpkgs.legacyPackages.x86_64-linux.nixpkgs-fmt;
Skyler Grey1e2187f2023-03-03 22:45:10 +0000165 };
Skyler Grey1e2187f2023-03-03 22:45:10 +0000166}