blob: c9de99c68403079d36e09f3a81babf10918b2571 [file] [log] [blame]
Skyler Greya0da6b22024-02-11 22:53:41 +00001{
Samuel Shuert02ffd1e2024-02-13 21:37:15 -05002 description = "The Chimera nix configuration flake, a shared system configuration";
Skyler Greya0da6b22024-02-11 22:53:41 +00003
4 inputs = {
Skyler Greya0da6b22024-02-11 22:53:41 +00005 anyrun = {
6 url = "github:Kirottu/anyrun";
7 inputs.nixpkgs.follows = "nixpkgs";
8 };
9
10 ewwsalmoomedits--eww-widgets = {
11 url = "github:saimoomedits/eww-widgets";
12 flake = false;
13 };
Skyler Grey4e230892024-02-13 22:58:46 +000014
Samuel Shuert2e42e672024-02-21 21:49:28 +000015 home-manager = {
16 url = "github:nix-community/home-manager";
17 inputs.nixpkgs.follows = "nixpkgs";
18 };
19
20 hyprland.url = "github:hyprwm/Hyprland";
21
22 nix-index-database = {
23 url = "github:nix-community/nix-index-database";
24 inputs.nixpkgs.follows = "nixpkgs";
25 };
26
Skyler Grey5db90f92024-02-25 11:24:31 +000027 nixos-hardware.url = "github:nixos/nixos-hardware/master";
28
Samuel Shuert2e42e672024-02-21 21:49:28 +000029 nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
30
Skyler Grey4e230892024-02-13 22:58:46 +000031 nur.url = "github:nix-community/nur";
Samuel Shuert2e42e672024-02-21 21:49:28 +000032
33 snowfall-lib = {
34 url = "github:snowfallorg/lib";
35 inputs.nixpkgs.follows = "nixpkgs";
36 };
37
38 sops-nix.url = "github:Mic92/sops-nix";
Samuel Shuert804f81b2024-02-21 22:20:01 +000039
40 templates.url = "git+https://git.clicks.codes/Templates";
Skyler Greya0da6b22024-02-11 22:53:41 +000041 };
42
Skyler Grey4e230892024-02-13 22:58:46 +000043 outputs =
44 { self, nixpkgs, ... }@inputs:
Samuel Shuertd7ad8db2024-02-20 20:53:34 +000045 let
46 extraHomeModules = [
Samuel Shuert659b5642024-02-23 20:47:43 +000047 inputs.anyrun.homeManagerModules.default
48 inputs.hyprland.homeManagerModules.default
49 inputs.nur.hmModules.nur
Samuel Shuert73a9d282024-02-23 18:43:32 +000050 inputs.nix-index-database.hmModules.nix-index
Samuel Shuertd7ad8db2024-02-20 20:53:34 +000051 ];
Samuel Shuert659b5642024-02-23 20:47:43 +000052 in
53 inputs.snowfall-lib.mkFlake {
Skyler Greya0da6b22024-02-11 22:53:41 +000054 inherit inputs;
55 src = ./.;
56
Samuel Shuertd7ad8db2024-02-20 20:53:34 +000057 homes.users."coded@shorthair".modules = extraHomeModules;
58
59 homes.users."minion@greylag".modules = extraHomeModules;
60
Samuel Shuert2e42e672024-02-21 21:49:28 +000061 systems.modules.nixos = [
Skyler Greya0da6b22024-02-11 22:53:41 +000062 inputs.hyprland.nixosModules.default
Samuel Shuert02ffd1e2024-02-13 21:37:15 -050063 inputs.nur.nixosModules.nur
Samuel Shuert2e42e672024-02-21 21:49:28 +000064 inputs.sops-nix.nixosModules.sops
Skyler Greya0da6b22024-02-11 22:53:41 +000065 ];
66
Skyler Grey5db90f92024-02-25 11:24:31 +000067 systems.hosts.greylag.modules = [
68 inputs.nixos-hardware.nixosModules.framework-13th-gen-intel
69 ];
70
Skyler Greya0da6b22024-02-11 22:53:41 +000071 snowfall = {
Skyler Grey4e230892024-02-13 22:58:46 +000072 namespace = "chimera";
Skyler Greya0da6b22024-02-11 22:53:41 +000073
Skyler Grey4e230892024-02-13 22:58:46 +000074 meta.name = "chimera";
75 meta.title = "Coded and Minion's Nix Configurations";
Skyler Greya0da6b22024-02-11 22:53:41 +000076 };
77
78 outputs-builder = channels: {
Skyler Grey4e230892024-02-13 22:58:46 +000079 formatter = nixpkgs.legacyPackages.${channels.nixpkgs.system}.nixfmt-rfc-style;
Skyler Greya0da6b22024-02-11 22:53:41 +000080 };
81
82 channels-config = {
83 allowUnfree = true;
84 };
85 };
86}