Skyler Grey | f08a619 | 2024-06-01 23:55:20 +0000 | [diff] [blame] | 1 | # SPDX-FileCopyrightText: 2024 Auxolotl Infrastructure Contributors |
| 2 | # SPDX-FileCopyrightText: 2024 Clicks Codes |
| 3 | # |
| 4 | # SPDX-License-Identifier: GPL-3.0-only |
| 5 | |
| 6 | { pkgs, modulesPath, ... }: |
| 7 | { |
| 8 | boot.loader.systemd-boot.enable = true; |
| 9 | boot.loader.efi.canTouchEfiVariables = true; |
| 10 | |
| 11 | time.timeZone = "Etc/UTC"; |
| 12 | |
| 13 | environment.systemPackages = with pkgs; [ neovim ]; |
| 14 | |
| 15 | clicks = { |
| 16 | nix.enable = true; |
| 17 | |
| 18 | security = { |
| 19 | doas.enable = true; |
| 20 | |
| 21 | acme = { |
| 22 | enable = true; |
| 23 | email = "minion@clicks.codes"; |
| 24 | }; |
| 25 | }; |
| 26 | |
| 27 | services = { |
| 28 | ssh.enable = true; |
| 29 | }; |
Skyler Grey | 40ae7a0 | 2024-06-06 21:22:25 +0000 | [diff] [blame] | 30 | |
| 31 | storage = { |
Skyler Grey | f4d05f0 | 2024-06-06 21:25:39 +0000 | [diff] [blame] | 32 | raid.enable = true; |
Skyler Grey | 40ae7a0 | 2024-06-06 21:22:25 +0000 | [diff] [blame] | 33 | impermanence = { |
| 34 | enable = true; |
Skyler Grey | d337740 | 2024-06-06 22:01:26 +0000 | [diff] [blame^] | 35 | devices = { |
| 36 | root = "/dev/disk/by-uuid/ab5c2f52-a737-4b29-a505-e3d0b9d0714c"; |
| 37 | persist = "/dev/md/a1d1:persist"; |
| 38 | }; |
Skyler Grey | 40ae7a0 | 2024-06-06 21:22:25 +0000 | [diff] [blame] | 39 | }; |
| 40 | }; |
Skyler Grey | f08a619 | 2024-06-01 23:55:20 +0000 | [diff] [blame] | 41 | }; |
| 42 | |
| 43 | boot.initrd.availableKernelModules = [ |
| 44 | "nvme" |
| 45 | "xhci_pci" |
| 46 | "ahci" |
| 47 | "usbhid" |
| 48 | "uas" |
| 49 | "usb_storage" |
| 50 | "sd_mod" |
| 51 | ]; |
| 52 | boot.initrd.kernelModules = [ ]; |
| 53 | boot.kernelModules = [ "kvm-amd" ]; |
| 54 | boot.extraModulePackages = [ ]; |
| 55 | |
Skyler Grey | 40ae7a0 | 2024-06-06 21:22:25 +0000 | [diff] [blame] | 56 | fileSystems."/nix" = { |
Skyler Grey | f08a619 | 2024-06-01 23:55:20 +0000 | [diff] [blame] | 57 | device = "/dev/disk/by-uuid/ab5c2f52-a737-4b29-a505-e3d0b9d0714c"; |
| 58 | fsType = "btrfs"; |
Skyler Grey | 40ae7a0 | 2024-06-06 21:22:25 +0000 | [diff] [blame] | 59 | options = [ "subvol=@nix" ]; |
Skyler Grey | f08a619 | 2024-06-01 23:55:20 +0000 | [diff] [blame] | 60 | }; |
| 61 | |
| 62 | fileSystems."/boot" = { |
| 63 | device = "/dev/disk/by-uuid/880D-BBAB"; |
| 64 | fsType = "vfat"; |
| 65 | options = [ |
| 66 | "fmask=0022" |
| 67 | "dmask=0022" |
| 68 | ]; |
| 69 | }; |
| 70 | |
| 71 | swapDevices = [ ]; |
| 72 | |
| 73 | networking.useDHCP = true; |
| 74 | |
| 75 | system.stateVersion = "24.05"; |
| 76 | } |